Nexus 6 device must be running Android version 6.0 or higher for the app to function correctly. 


This is a device specific issue and should be resolved once the android version is installed and updated on your device.


To find out which version your Nexus 6 is running got Settings > About Device > version


To see if there is a software update available for your Nexus 6 go to About Device > Software Updates > check for updates.